Jump to content
tr1te

Черная модель в ZBrush`е.

Recommended Posts

Я загружаю модель, и она абсолютно черная. Перестает быть черной, только если я в закладке текстур наживаю новая текстура. Проблема в том что из-за этого я не могу спотлайтом воспользоваться. Ибо когда рисую спотлайтом по черной модели, я не вижу что у меня получается. Но когда нажимаю текстура из полипейнта, то вижу что где водил там и нанеслась. :)

Из-за чего это может быть, и как это исправить?

Share this post


Link to post
Share on other sites

Вот так выглядит модель:

На первом Colorize включен, и модель отображается без шейдера, а на втором скрине выключен.

woColorize.thumb.jpg.23c55a51975348f19379d842818950a4.jpg

Colorize.thumb.jpg.9382cd4e623ea5ca1943dc5c59cb19b7.jpg

Share this post


Link to post
Share on other sites

Разобрался, надо было выбрать MChanel и пройтись кистью по всей модели любым шейдером. Заодно узнал о такой функции, я так понимаю это нужно для того чтобы одной модели задать несколько разных матов по каналам. Полезная штука.

Share this post


Link to post
Share on other sites

А можно поподробнее. Где находится данный мчаннел - если имеешь в виду "рисование материалом", то не помогло и манипуляции с колорайзом не помогают.

Share this post


Link to post
Share on other sites

Ну я надеюсь ты знаешь где кнопка "RGB", которая служит для того чтобы по модели рисовать Diffuse. Так вот канал материала находиться справа от нее, с буквой "M", на скриншоте сверху это видно. И с помощью этой кнопки можно задавать канал материала, то бишь на одну модель наложить несколько разных матов. Выбираешь материал который нужно, нажимаешь эту кнопку ,и рисуешь кистью там где должен быть выбранный мат.

Share this post


Link to post
Share on other sites

У тебя на скриншоте отмечено "Mrgb", а это не то. Надо справа от "RGB", там просто буква "M".

Share this post


Link to post
Share on other sites

Хм. тогда не знаю чем помочь, можете скинуть файл, я поковыряю, любопытно.

Share this post


Link to post
Share on other sites

http://rghost.ru/14833961

 

Если открывать ее как первую модель при запуске браша - остается данный эффект, если открыть вначале нормальную модель, а затем ее то все будет нормально. Мистический зибраш, однако.

Share this post


Link to post
Share on other sites

Да, действительно странная вещь. Ну если вам не критичны деление решетки, и не жалко его потерять, то можете экспортнуть модель в obj, открыть браш с новой сценой и импортнуть, и все будет нормально.

Share this post


Link to post
Share on other sites

JLivy

тест №1

открыл браш, загрузил твою модель(она серая) попытался переключиться между тулами, они тоже все серые. не понятно в общем.

 

тест №2

открыл браш, создал обычную сферу, все хорошо, загрузил твою модель и все стало так как нужно, пересохранил твою модель и теперь она работает как надо.

shot_02.thumb.jpg.de483cc6f2e0d9579484c1348339519f.jpg

shot_01.thumb.jpg.8eba75607c40ff0dbcf06fb04c1992e1.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use